Dec 122005
 

Geçen hafta bir denemek için merakla Debian Unstable deposundan GNOME’ u kuruverdim sisteme. Herkesin dilinde olan “GNOME KDE’ den hızlıdır” sözüne de dayanarak, belki biraz daha hızlı bir çalışma ortamı yakalarım düşüncesi de aklımdan geçmedi değil. GNOME’ u kurduktan sonra oldukça hızlı açıldı. Nautilus, Konqueror’ a göre daha hızlı çalışıyordu (pencere açılışları ve önizleme resmi yüklemesi). Ancak Debian’ daki GNOME ile gelen standart temayı pek sevmediğim için sisteme makyaj yapmam gerekti. Industrial temasını seçtim ve seyrine baktım. Gerçekten çok hoş görünmeye başladı. Biraz kurcaladıktan sonra canımı sıkan bir şey oldu: Evet GNOME, KDE’ ye oranla daha az RAM harcıyordu ama GTK+/GNOME bileşenleriyle etkileşim QT/KDE bileşenlerine oranla çok yavaş. Bir menüye tıkladığımda açılması küçük bir zaman alıyordu. O anda da fare hareket etmiyordu. Yani GUI bileşenleri çok geç tepki veriyordu. Ertesi gün dayanamayarak tekrar KDE’ ye geçtim ve eskisi gibi devam ettim. Ancak bir şey farkettim. Lipstik temalı KDE altında kullandığım diğer GTK+ uygulamaları da (Firefox, XChat ve Gaim) aynı şekilde tepkileri geç veriyordu. GTK+ ile QT temalarını kullanma özelliğini kaldırıp standart GTK+ temasını kullanmaya başlayınca tepkiler hızlandı.

Demek ki neymiş? GNOME KDE’ den yavaşmış. 🙂

  One Response to “GNOME? Evet Çok Yavaş”

  1. The first Feynman clip is interesting, is that his answer itself shows that his answer is simplistic (also amusing in light of the second clip). Interesting because, as Feynman no doubt knew, we can easily be mistaken about what we are seeing, and it is only by testing what we are seeing in other ways — such as by reaching out to the "steak" we think we see and attempting to manipulate it — that we can conclude that what we see is what is "really" there.

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)